Menu

Virtual Geek

Tales from real IT system administrators world and non-production environment

VMWARE VCENTER 6.5 UPGRADATION ERROR

November 20, 2016 08:15PM

Today I upgraded my vCenter Server version 6.0 to 6.5 (UPGRADING FROM VMWARE VCENTER 6.0 TO 6.5 PROCEDURE AND VSPHERE HTML5 WEB CLIENT) and I would like to discuss below two errors I faced while update, Rest everything was smooth. After this vCenter Single sign-on and vCenter Server Credentials screen and I got 2 Errors and not able to proceed ahead.

vmware vcenter server 6.5.0 upgrade errors vcenter single sign-on  and vcenter server credentials

Error 1

Error: A problem occurred during authentication to the legacy vCenter Server using the provided credentials.
Resolution: Verify that the legacy vCenter Server is up and running. Verify that you provided the correct vCenter Single Sing-on credentials.

vmware vsphere vcenter 6.5 installation upgrade error vcenter service not running

As given in first resolution, When checked vCenter server service, I found it is stopped, I started it and Upgrade went Ahead, My typed credentials were correct.

Upgrade successfully vmware vCenter Server Service stopped started


Error 2

Error: User running the upgrade does not have 'Replace a process level token' privilege.
Resolution: Assign 'Replace a process level token' privilege to the user.

vmware vcenter server 6.5 upgradation installation error replace a process level token priviledge

To resolve it open local Group Policy editor of the vCenter Server. Open Run and type gpedit.msc.

vmware vsphere vcenter upgrade installation error resolution, gpedit.msc token privileges

Collapse Computer configuration and go to Security Settings >> Local Policies >> User Rights Assignment, and in the right hand side find Replace a process level token right click on it, go to properties. Add user or group, Add the service account (Vcenter service will be running using this account as shown in first screenshot). Check the names and click OK to add it.

vmware vcenter 6.5 upgrade local group policy editor replace a process level token

If everything is successful, you will see message Running pre-upgrade checks. this could take few minutes...

 Vmware vcenter server 6.5 upgradation installation eroor, running pre-upgrade checks. This could take a few minutes...

VUM Error 3

VSPHERE UPDATE MANAGER 6.5 UPGRADE AND VSPHERE WEB CLIENT PLUG-IN INTEGRATION

Useful Links
PART 1 : VCENTER SQL DATABASE AND ODBC DSN CREATION
PART 2 : VCENTER SERVER 6.0 INSTALLATION ON WINDOWS 2012 R2
PART 3.1 : VMWARE VSPHERE UPDATE MANAGER INSTALLATION ON WINDOWS 2012 R2
PART 3.2 : VMWARE VSPHERE UPDATE MANAGER PLUG-IN INSTALLATION ON VSPHERE CLIENT
ESXI 6.5 UPGRADE INSTALLATION AND UI HTML WEB CLIENT

Go Back

Not only that you fixed my problem, but I've also posted an update to your blog URL to the VMware KB which is useless.
Thank you!



Comment